1. Welcome,
    SXSNation is a UTV Community that brings enthusiasts together regardless of brand, a place to find local rides, partake in discussion, buy or sell within a marketplace, or just rant about anything side by sides. Interact directly with top Vendors in the Industry, find exclusive discounts and specials and participate in weekly giveaways! If you haven't registered yet, what are you waiting for?
    Dismiss Notice

2016 Ranger xp900 wont start

Discussion in 'New Member Introduction' started by Christopherb1229, Apr 23, 2020.

Users Viewing Thread (Users: 0, Guests: 0)

?

My ranger wont Start

  1. Fixes

    0 vote(s)
    0.0%
  2. answers

    1 vote(s)
    100.0%
  1. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

    I am having trouble with my 2016 xp900 a few days ago it was running rough (Stalling out at Idol) Battery was 3.5 years old so I replaced it. Went to start machine and it just rolls over . Checked plugs and they were dry, Checked for spark and there was no spark Engine light is now on. Ordered a new coil and installed it no change still just rolls over with no spark.
    All relays are good fuses are good.Fuel pump is good and running, Shot with starting fluid and nothing. Im leaning toward the ECU being bad . if anyone could help me I would appreciate it

    Chris
     
  2. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    601
    Likes Received:
    332
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    With no spark starting fluid won't work and will do damage by drying the cylinder out. Any codes?
     
  3. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

    I guess i should have stated i tried the starter fluid at the beginning of the process fully aware your engine wont start without spark!
     
  4. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    601
    Likes Received:
    332
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    OK, so any codes?
     
  5. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

  6. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    601
    Likes Received:
    332
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    Yeah, I'm leaning to ECM, check plug for any burnt spots. I know you said fuses OK but did you test them or just do a visual, there is one for the coil, light test the red wire at the coil.
     
  7. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

    Yeah there isn’t any burnt spots its spotless.
     
  8. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    601
    Likes Received:
    332
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    Did you test the wire at the coil? What you need now is a buddy willing to let you use his ECM, or maybe try Power Sports Nation for a used one, $150. If you got a good dealer might want to let them plug their computer up to it, maybe even a re-flash, i'm thinking out loud.....
     
  9. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

    Put a new ecu in im not sure if this is a code or what but heres the first number 0520276. the next one is 151 either way its not starting. Any input?
     
  10. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    601
    Likes Received:
    332
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    I don't have the software to copy the manual page. Should be a number on the left and range from 0-9, indicates the number of codes present. To the right of that is a number from 2-6 digits in length and is the suspected area of fault. Below that is 1-2 digit number and is the fault mode. 520276 is the throttle position sensor, not sure on the 151, maybe throttle body. I'm guessing the codes popped up? to retrieve them toggle the button till you see CK ENG, then hold the button to access codes. Is this a new ECM or used/borrowed?
     
  11. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

    It’s a used one I found on eBay
     
  12. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

    I keep hearing a noise towards the back of the engine where it hooks into the air intake like a buzzing or somethings turning on and off
     
  13. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

    FDC31602-5E57-4088-8183-A13713F79115.jpeg
     

    Attached Files:

  14. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

    Im still not getting any volts going to the coil either
     
  15. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    601
    Likes Received:
    332
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    Well the 51 is throttle position voltage to high. The other is throttle position sensor, neither passed test. Did you put a NEW battery in?
     
  16. Christopherb1229

    Christopherb1229 Chris SXS Nation Rookie

    Joined:
    Apr 23, 2020
    Posts:
    10
    Likes Received:
    0
    Location:
    michigan
    Side X Side(s):

    Ranger xp900

    New battery. Put my original ecu in and i get code 636 with a 2 under it.
     
  17. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    601
    Likes Received:
    332
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    Fault in the crank position sensor.

    I had to come back and edit this, manual actually calls it a plausibility fault, must be there way to CYA. I've seen a couple of places this sensor to be a problem.
     
    Last edited: Apr 29, 2020

Share This Page