1. Welcome,
    SXSNation is a UTV Community that brings enthusiasts together regardless of brand, a place to find local rides, partake in discussion, buy or sell within a marketplace, or just rant about anything side by sides. Interact directly with top Vendors in the Industry, find exclusive discounts and specials and participate in weekly giveaways! If you haven't registered yet, what are you waiting for?
    Dismiss Notice

2019 Dominator 1000

Discussion in 'Odes Nation' started by nmrohn, Mar 11, 2020.

Users Viewing Thread (Users: 0, Guests: 0)

  1. nmrohn

    nmrohn Nick SXS Nation Rookie

    Joined:
    Mar 11, 2020
    Posts:
    5
    Likes Received:
    0
    Location:
    Lake Havasu City, Az
    Side X Side(s):

    2019 Odes Dominator x4 1000

    Hey guys so I just got my 2019 dominator yesterday and I realized on acceleration from a dead stop it sometimes has a banging or popping noise. I’m new to these machines so any help I can get is much appreciated!
     
  2. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    63
    Likes Received:
    9
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    Not sure what it would be but try the simple stuff first, gas, spark plugs, plug wires etc. That's about all I have. Good luck.
     
  3. nmrohn

    nmrohn Nick SXS Nation Rookie

    Joined:
    Mar 11, 2020
    Posts:
    5
    Likes Received:
    0
    Location:
    Lake Havasu City, Az
    Side X Side(s):

    2019 Odes Dominator x4 1000

    Thanks Jack.
     
  4. Captain68

    Captain68 Kirk SXS Nation Rookie

    Joined:
    Mar 26, 2018
    Posts:
    7
    Likes Received:
    2
    Location:
    Missouri
    Check your shift linkage. Mine was off alittle and would pop when accelerating.
     
  5. nmrohn

    nmrohn Nick SXS Nation Rookie

    Joined:
    Mar 11, 2020
    Posts:
    5
    Likes Received:
    0
    Location:
    Lake Havasu City, Az
    Side X Side(s):

    2019 Odes Dominator x4 1000

    Will do I appreciate the reply!
     
  6. Nomadczm

    Nomadczm Damon SXS Nation Rookie

    Joined:
    Apr 30, 2019
    Posts:
    8
    Likes Received:
    0
    Location:
    Cozumel México
    Side X Side(s):

    2006 rhino 660

    It could be the cvt weights engaging when at a dead stop?

    Just got my 2019 1000 also, You have lots of gear whine in yours?
     
  7. nmrohn

    nmrohn Nick SXS Nation Rookie

    Joined:
    Mar 11, 2020
    Posts:
    5
    Likes Received:
    0
    Location:
    Lake Havasu City, Az
    Side X Side(s):

    2019 Odes Dominator x4 1000

    Yes there is quite a bit of gear whine for sure. Today I tried just easing gently into the gas and it wouldn’t do it but if I give it just the normal amount of gas to accelerate it “bangs” once and the runs fine until stoping and accelerating again. It runs great but that noise make me paranoid that I have bigger issues.

    On that note I did find that the hose clamp that holds the air filter hoses together up under the dash was disconnected so I dropped the front skid plate and reconnected and hope maybe that fixes it? Or at least eliminates some of the noise it makes. Keep me up to date on anything you find and thanks for replying!
     
  8. Nomadczm

    Nomadczm Damon SXS Nation Rookie

    Joined:
    Apr 30, 2019
    Posts:
    8
    Likes Received:
    0
    Location:
    Cozumel México
    Side X Side(s):

    2006 rhino 660

    Sounds like the cvt weights sliding to engage to me. Mine does the same.
     
  9. nmrohn

    nmrohn Nick SXS Nation Rookie

    Joined:
    Mar 11, 2020
    Posts:
    5
    Likes Received:
    0
    Location:
    Lake Havasu City, Az
    Side X Side(s):

    2019 Odes Dominator x4 1000

    Is there anything I can do to fix it or is it just something I have to live with?
     
  10. Nomadczm

    Nomadczm Damon SXS Nation Rookie

    Joined:
    Apr 30, 2019
    Posts:
    8
    Likes Received:
    0
    Location:
    Cozumel México
    Side X Side(s):

    2006 rhino 660

    I'm not super familiar with the cvtech system, but maybe someone sell a different style weight. It might also have to do with the fact that the weights are greaseless. Might just have to deal with it though. Maybe take a video/sound clip of the noise and I could tell ya if it's the same sound as mine.
     
  11. RetiredGuy

    RetiredGuy Michael SXS Nation Rookie

    Joined:
    Jan 29, 2020
    Posts:
    1
    Likes Received:
    0
    Location:
    Sun City Arizona
    Side X Side(s):

    2020 Bennche X4 1000cc SxS

    Hi Nick, I didn't go with an Odes due to their filed bankruptcy but rather a Bennche which was a partner company to Odes that broke away due to Odes filing bankruptcy. Mine is a new 2020 X4 1000. Did the same thing at first.
    While breaking in I changed out the tires to all terrain so I could break it in on the street around the neighborhood keeping it under 25 mph.
    I learned by letting it warm up for 5 minutes getting internal temp up to 100f. It would shift and accelerate fine. Start it a go gets me a big bang. I'll be discussing with my dealer at my 200 mile tune up.
    I'd like to know if it is tied to the CV weights or linkage adjustment.
    Thanks for posting
    Michael
     
  12. Oldguy

    Oldguy Randy SXS Nation Regular

    Joined:
    Dec 25, 2017
    Posts:
    105
    Likes Received:
    41
    Location:
    Nashua Minnesota
    Side X Side(s):

    Odes Dominator X LT

    I have found Odes Owners Group (official) on f.b. as well as Odes Mechanics, They are a great source of info. Another source is Motorcycle Doctoor out of Camdenton Mo.
     

Share This Page