1. Welcome,
    SXSNation is a UTV Community that brings enthusiasts together regardless of brand, a place to find local rides, partake in discussion, buy or sell within a marketplace, or just rant about anything side by sides. Interact directly with top Vendors in the Industry, find exclusive discounts and specials and participate in weekly giveaways! If you haven't registered yet, what are you waiting for?
    Dismiss Notice

A couple Magneto Case questions

Discussion in 'General Side X Side Discussions' started by Speg, Nov 16, 2020.

Users Viewing Thread (Users: 0, Guests: 0)

  1. Speg

    Speg Greg SXS Nation Rookie

    Joined:
    Nov 2, 2020
    Posts:
    3
    Likes Received:
    0
    Location:
    Nova Scotia
    Side X Side(s):

    Wildcat 1000

    Hey. I purchased a used Wildcat 1000 and I was getting a P0336 code. I looked at the 2 sets of wires coming out of the Magneto case and noticed 2 things where it plugs into the harness. Usually when you plug 2 wires together, they snap/click together. On the bigger connector plug, there is nothing for it to click. It slides on/off.
    The smaller one when I pulled it out, water came out of it. I cleaned it all up and seems to be fine.

    Before I checked the wires, I wanted to inspect the magneto and when I pulled all the bolts off, oil came out. I panicked and put it back together. I think I lost about 2 ounces of oil. From what I'm reading, it's normal for oil to be in there but I cannot find ANYTHING to say how much and do I add oil to it or does it take it from the engine?!

    Thanks in advance!
     
  2. JOE YOUNT

    JOE YOUNT joseph SXS Nation Rookie

    Joined:
    Jul 21, 2020
    Posts:
    23
    Likes Received:
    1
    Location:
    TUCSON
    Side X Side(s):

    2015 POLARIS RANGER XP 900

    Don't know about the magnito but all your electrical connections need di-electric grease to help keep them dry.
     

Share This Page