1. Welcome,
    SXSNation is a UTV Community that brings enthusiasts together regardless of brand, a place to find local rides, partake in discussion, buy or sell within a marketplace, or just rant about anything side by sides. Interact directly with top Vendors in the Industry, find exclusive discounts and specials and participate in weekly giveaways! If you haven't registered yet, what are you waiting for?
    Dismiss Notice

Charging

Discussion in 'General Side X Side Discussions' started by Dwight, Jan 10, 2020.

Users Viewing Thread (Users: 0, Guests: 0)

  1. Dwight

    Dwight Dwight SXS Nation Rookie

    Joined:
    Jan 10, 2020
    Posts:
    3
    Likes Received:
    0
    Location:
    Tn
    Side X Side(s):

    2010 polaris ranger 800xp

    My 2010 polaris ranger started over charging put a new mosfet voltage regulator on still over charging. Checked the stator 19.2 across all three at 1100 rpms 34 at3000 74 at 5000
    did i get a bad new voltage regulator
     
    Last edited: Jan 10, 2020
  2. airshot

    airshot Ken SXS Nation Expert

    Joined:
    Dec 20, 2016
    Posts:
    678
    Likes Received:
    332
    Location:
    Perrysburg, Ohio
    Side X Side(s):

    Kymco 450i UXV

    Make sure your battery does not have a shorted cell, I have saw this when a battery has a direct short inside.
     
  3. Dwight

    Dwight Dwight SXS Nation Rookie

    Joined:
    Jan 10, 2020
    Posts:
    3
    Likes Received:
    0
    Location:
    Tn
    Side X Side(s):

    2010 polaris ranger 800xp

    Put my lawn mower battery in it same thing
     
  4. Jungleman

    Jungleman SXS Nation Regular

    Joined:
    Feb 25, 2016
    Posts:
    87
    Likes Received:
    73
    Location:
    Caribbean
    Side X Side(s):

    2007 Polaris Ranger 700XP LE

    Assuming you meant 0.192 Ohms across all three I would say you got a bad regulator . If you got 19.2 Ohms.....(not likely) you have a miracle stator problem.
     
  5. Dwight

    Dwight Dwight SXS Nation Rookie

    Joined:
    Jan 10, 2020
    Posts:
    3
    Likes Received:
    0
    Location:
    Tn
    Side X Side(s):

    2010 polaris ranger 800xp

    No it has 19 volts ac on all 3 leads at the stator while running
     
  6. Jungleman

    Jungleman SXS Nation Regular

    Joined:
    Feb 25, 2016
    Posts:
    87
    Likes Received:
    73
    Location:
    Caribbean
    Side X Side(s):

    2007 Polaris Ranger 700XP LE

    Doh........ VOLTS running . Stator is putting out within spec at the RPM levels you quoted. I think you need to take another look at your aftermarket voltage rgulator.
     
    Seastacker and Rhoda Mule like this.

Share This Page