1. Welcome,
    SXSNation is a UTV Community that brings enthusiasts together regardless of brand, a place to find local rides, partake in discussion, buy or sell within a marketplace, or just rant about anything side by sides. Interact directly with top Vendors in the Industry, find exclusive discounts and specials and participate in weekly giveaways! If you haven't registered yet, what are you waiting for?
    Dismiss Notice

Polaris RZR help!

Discussion in 'General Side X Side Discussions' started by KellBell, Mar 22, 2020.

Users Viewing Thread (Users: 0, Guests: 0)

  1. KellBell

    KellBell Kelly SXS Nation Rookie

    Joined:
    Mar 22, 2020
    Posts:
    1
    Likes Received:
    0
    Location:
    Michigan
    Side X Side(s):

    Polaris RZR 900

    I have a 2016? Polaris rzr 900 and rolled it upside down doing a donut a week ago in the dirt. Once I got it back over it wouldn’t start the first couple times then it did and ran fine back to the garage. It wouldn’t start this week just clicked and sometimes sounded like it wanted to turn over but couldn’t. Charged the battery and put it back in. It ran fine but started to overheat while driving it and the battery ended up frying the starter solenoid. (That battery was only 3 months old and a smaller 12v Deka ETX20L which we knew was the wrong battery to begin with but never had an issue after unplugging light bar and speakers). So swapped out the battery and put a new starter solenoid in too. Ran perfect until the next day. Same problem as before... Jumped the battery then about 10 mins later it sputtered while driving and speed declined to 20mph pedal down to get back. It was only driven on cement at that point and 30mph max through a subdivision. It also through a red/orange light on the dash but I don’t have the manual so not sure what it means. I’m not sure where to go with this. I am going to get the bigger battery tomorrow to see if that helps but it sounds like something may be loose somewhere and need some advice on how to approach this issue!!
     
  2. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    587
    Likes Received:
    331
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    It sounds like it went into limp home mode, any codes?
     
  3. Keebler

    Keebler Frank SXS Nation Rookie

    Joined:
    Feb 26, 2020
    Posts:
    5
    Likes Received:
    0
    Location:
    St Charles, Mo
    Side X Side(s):

    None yet, looking at Pioneer 500

    I am not sure about the battery issue, but you mentioned overheating after the role over. I would bleed the cooling system to make sure you don't have an air pocket in the cooling system. I think your RZR has a limp mode when it overheats, kinda like your description of only being able to do 20 mph on the way back home. The fried starter solenoid could be caused if you continuously crank the engine for long periods of time. On other vehicles I have owned it is recommended that you crank no longer than 10 seconds at a time with several minutes between starting attempts.
     
  4. Mwaldo

    Mwaldo Michael SXS Nation Regular

    Joined:
    Feb 2, 2018
    Posts:
    30
    Likes Received:
    9
    Location:
    Hibbing
    Side X Side(s):

    Ranger 700 6x6 2006

    Does your model not have a full speedo, it will give you the fault code numbers, or you can turn the key from off to on 3 times and then count the 2 digit blinks of the light
    Look up the codes on line
     

Share This Page