1. Welcome,
    SXSNation is a UTV Community that brings enthusiasts together regardless of brand, a place to find local rides, partake in discussion, buy or sell within a marketplace, or just rant about anything side by sides. Interact directly with top Vendors in the Industry, find exclusive discounts and specials and participate in weekly giveaways! If you haven't registered yet, what are you waiting for?
    Dismiss Notice

Replaced voltage regulator now Rzr won’t crank

Discussion in '800: 50", S, 2 & 4 seaters' started by Moler15, May 16, 2018 at 2:01 PM.

Users Viewing Thread (Users: 0, Guests: 0)

  1. Moler15

    Moler15 Nikolas SXS Nation Rookie

    Joined:
    Wednesday
    Posts:
    3
    Likes Received:
    0
    Location:
    Oklahoma
    Side X Side(s):

    08 Rzr 800

    Replaced the voltage regulator in my 08 Rzr 800 because battery light was flashing on a brand new battery and it kept dying while driving it now I can’t even get the Rzr to crank with old or new regulator. Any suggestions would be helpful thank you
     
  2. Seastacker

    Seastacker Carl Moderator

    Joined:
    Feb 1, 2016
    Posts:
    1,860
    Likes Received:
    1,136
    Location:
    SE Michigan
    Side X Side(s):

    2013 Polaris Ranger 500 EFI Mid-Size

    I would start simple and check battery voltage with a multi-meter. Weak batteries will cause all sorts of odd issues on these things. If your regulator was bad, it may have also taken out the battery as well.

    upload_2018-5-16_14-52-50.png
     
    DieselFume, Moler15 and Jungleman like this.
  3. Moler15

    Moler15 Nikolas SXS Nation Rookie

    Joined:
    Wednesday
    Posts:
    3
    Likes Received:
    0
    Location:
    Oklahoma
    Side X Side(s):

    08 Rzr 800

    Checked voltage everything is running normal. Any other suggestions?
     
  4. DieselFume

    DieselFume Adam Moderator

    Joined:
    Feb 24, 2016
    Posts:
    1,643
    Likes Received:
    1,177
    Location:
    Montana
    Side X Side(s):

    2013 XP 800 Ranger, Three 2017 Polaris 570 Full Sizes. All subjected to hard ranch work, long hours and rough conditions. 5 years or bust!

    I'm with Carl,

    I'd say either your battery isn't fully charged, or your battery has an issue. Wouldn't be the first battery that a charging system has taken out. They aren't designed for deep discharging and re-charging.

    What brand of battery is it? Is it a wal mart brand or a name brand?

    Check your battery cables as well, a slightly loose cable can cause erratic starting issues. Could also try jumping the starter solenoid posts to see if it cranks that way- if it does then you either have a bad solenoid, or brake press switch
     
    Moler15 and Jungleman like this.
  5. Moler15

    Moler15 Nikolas SXS Nation Rookie

    Joined:
    Wednesday
    Posts:
    3
    Likes Received:
    0
    Location:
    Oklahoma
    Side X Side(s):

    08 Rzr 800

    It is a Walmart battery. It’s a lawn mower battery, I replaced it shortly after I bought it because it was more powerful than the original battery and I was having issues with the first battery when I turned the lights on the rzr would die. I will check the cables out.
     
  6. Jungleman

    Jungleman SXS Nation Regular

    Joined:
    Feb 25, 2016
    Posts:
    64
    Likes Received:
    52
    Location:
    Caribbean
    Side X Side(s):

    2007 Polaris Ranger 700XP LE

    Hmmmmm, Walmart & a lawn mower battery tah boot. Check the cables and then look at a good replacement battery. OEM battery part number 4011496 cross references with this ODYSSEY ... Odyssey PC545 Battery | AGM Powersports Battery
     
    Last edited: May 19, 2018 at 5:28 PM

Share This Page