1. Welcome,
    SXSNation is a UTV Community that brings enthusiasts together regardless of brand, a place to find local rides, partake in discussion, buy or sell within a marketplace, or just rant about anything side by sides. Interact directly with top Vendors in the Industry, find exclusive discounts and specials and participate in weekly giveaways! If you haven't registered yet, what are you waiting for?
    Dismiss Notice

shifter linkage

Discussion in 'Odes Nation' started by jweese1, Apr 7, 2018.

Users Viewing Thread (Users: 0, Guests: 0)

  1. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    I recently purchased a used 2015 Odes 800X Dominator side by side. I was told the shift linkage was out of adjustment is why it wouldn't go in gear quite right. I have set the linkage exactly how the owners manual says to. It goes into low, high and neutral pretty good. It will go into reverse only after messing with for a while and I've never gotten it into park. Can anyone help me???
     
  2. Seastacker

    Seastacker Carl Moderator

    Joined:
    Feb 1, 2016
    Posts:
    2,509
    Likes Received:
    1,731
    Location:
    SE Michigan
    Side X Side(s):

    2019 Polaris General 4

    If you unhook the linkage at the trans will it go into each gear ok? If so it sounds like there cable is stretched out or there is something loose in the linkage somewhere.
     
  3. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    There is no cable on this one there is a solid, adjustable rod that runs between the trans and the shifter. By turning the rod, you adjust the distance between the shifter and trans. Thank you for your answer.
     
    Seastacker likes this.
  4. Rockin Ronnie

    Rockin Ronnie Ron Moderator

    Joined:
    May 20, 2017
    Posts:
    619
    Likes Received:
    424
    Location:
    Evart, Michigan
    Side X Side(s):

    17 Polaris General
    13 Polaris Ranger

    You may want to check the shifter make sure all the pivit's are tight no missing bushings or broken parts that is not allowing it to move linkage correctly Just a thought!
     
  5. Seastacker

    Seastacker Carl Moderator

    Joined:
    Feb 1, 2016
    Posts:
    2,509
    Likes Received:
    1,731
    Location:
    SE Michigan
    Side X Side(s):

    2019 Polaris General 4

    Does it shift hard into the gears that do work? Makes me wonder if the rod is bent somehow since there is no cable. Also, as Ron suggested, check all pivot points and bushings for slop/ excessive play.
     
  6. Curt

    Curt Administrator

    Joined:
    Nov 12, 2015
    Posts:
    2,349
    Likes Received:
    1,286
    Location:
    Michigan
    Is there more than one hole on the shifter arm? The closer to the arm the shorter the distance to shift. It may make a difference.
     
  7. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    I first posted back in April, I took it to a dealer who told me that the trans. was bad and needed a new one to the tune of $1800. Decided to just ride it until the the trans. went out completely. It is now mid-September and it's going into reverse better and it is even going into park now. Any ideas on what's going on?
     
  8. 5thgenlude0505

    5thgenlude0505 Tommy SXS Nation Rookie

    Joined:
    Oct 22, 2018
    Posts:
    2
    Likes Received:
    0
    Location:
    Ny
    Side X Side(s):

    2014 dominator 800 4 door

    Did you figure it out mine also does this only rocking it back and fourth allows me to get park ...its the same with shifter disconnected just going right off trans
     
  9. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    No, I haven't ridden it for a while but my grandson has. He put it in the garage one night and got it into park. That was the first time I had seen it in park. It does seem to be going into reverse better and now goes into park. No explanation from here and apparently noone else knows either. Good Luck and keep in touch.
     
  10. Odes in Norway

    Odes in Norway Torstein SXS Nation Rookie

    Joined:
    Oct 10, 2018
    Posts:
    8
    Likes Received:
    7
    Location:
    Norway
    Side X Side(s):

    2016 Odes 800

    Did you figure out what the problem was?
    Have you fixed it to your satisfaction ?
     
  11. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    The problem seems to have fixed itself. The transmission seems to be working fine now.
     
  12. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    Well, it is May and my transmission seems to be acting up again. will barely go into reverse and will not go into park. Some of you were having the same experience. Have you found anything out? Thanks.
     
  13. Oldguy

    Oldguy Randy SXS Nation Regular

    Joined:
    Dec 25, 2017
    Posts:
    56
    Likes Received:
    30
    Location:
    Nashua Minnesota
    Side X Side(s):

    Odes Dominator X LT

    I had to replace my belt, when I got it back it was a bear to shift. Will shift with the engine of just fine, as soon as you start it shifting becomes park and low, you have to push that hard. Dealer said he adjusted idle, noticed last night when in gear it "creeps" going to try backing off idle ....if I can find it
     
  14. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    As of now, mine only goes into H,L,N. It WILL NOT go into R or P at all. Very frustrated!
     
  15. airshot

    airshot Ken SXS Nation Team Leader

    Joined:
    Dec 20, 2016
    Posts:
    457
    Likes Received:
    259
    Location:
    Perrysburg, Ohio
    Side X Side(s):

    Kymco 450i UXV

    Did you ever disconnect the linkage and see if the trans will shift ok by manually shifting the arm on the trans?
     
  16. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    I have not since it started acting up again but I will and I'll let you know.
     
  17. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    506
    Likes Received:
    300
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    Take the belt off and see if it will shift through the gears.
     
  18. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    I'll do it when I get to work on it. Thanks. Anyone else? I appreciate the tips.
     
  19. Pede

    Pede SXS Nation Expert

    Joined:
    Mar 6, 2016
    Posts:
    506
    Likes Received:
    300
    Location:
    West central Illinois
    Side X Side(s):

    09 700 Ranger

    On second thought, can you feel it shift into all the gears when it's not running?
     
  20. jweese1

    jweese1 Jack SXS Nation Regular

    Joined:
    Apr 7, 2018
    Posts:
    33
    Likes Received:
    6
    Location:
    Aledo, IL
    Side X Side(s):

    2015 Odes 800x Dominator

    no, when it's not running, it doesn't want to shift into any gear. When it's running, it will shift into L, H and N. When you try to put in to R, it's like it hits a stop and will go no further.
     

Share This Page